>2% Writer | 000

30

Writer,

la conception rédaction
des documents texte

Clément Cordaro

riter, le module de traitement de
Wtexte, posséde toutes les qualités

nécessaires a la rédaction, I'organi-
sation et le formatage de documents texte,
de maniére moderne et efficace. Il permet,
grace au styliste notamment, de dissocier le
contenu de la mise en forme, ce qui est idéal
pour I'export dans d’autres formats. Il assure
ainsi l'interopérabilité et la portabilité des
données. Lextension des fichiers de Writer
est «.odt ».

La présentation des documents n’est pas
non plus oubliée puisque Writer dispose de
tous les outils de présentation et de mise en
forme : listes, tableaux, images, dessins...
Math, le module intégré autorisant la géné-
ration de formules mathématiques, s’'avére
également trés utile pour la rédaction de
documents scientifiques.

Lobjet de cet article n'est pas de lister
toutes les fonctionnalités de Writer et toutes
leurs propriétés, mais plutot de présenter les
principales, notamment au travers la création
d’'un document consacré au publipostage
avec OpenOffice.org.

Les styles

Un style est un ensemble de régles de mise
en forme qui s’appliquent a des éléments
identiques : titres, paragraphes, listes a pu-
ces... Grace aux styles, le document est
rendu homogéne dans sa forme et sa mise
en page est facilitée.

A titre d’exemple, pour modifier toutes
les listes a puces, il suffit de modifier le style
correspondant. Lors de la rédaction de longs
documents, I'utilisation des styles s’avére
ainsi indispensable.

La fenétre Styles et formatage (NB : Les
références des menus citées seront celles
de la version 2.2), anciennement « Styliste »
(nous utiliserons les deux appellations), est
I'une des particularités d’OpenOffice.org car
si MS Office posséde une fenétre du méme
nom, celle de la suite libre est plus puissante
et plus polyvalente.

Cette fenétre est accessible dans la barre
d’outils Formatage, en cliquant sur le bouton
le plus a gauche, ou plus simplement en ap-
puyant sur la touche [F11] du clavier.

Les styles sont nommeés et hiérarchisés,
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et un grand nombre de styles sont
prédéfinis dans OpenOffice.org. lls
sont répartis en cing catégories :
styles de paragraphe, styles de carac-
téres, styles de cadre, styles de page
et styles de liste (numérotation ou
a puces). Il est bien entendu possible
de créer ses propres styles en cliquant
simplement sur le bouton droit de la
souris dans I'une des catégories, puis
en sélectionnant Nouveau.

Dans la fenétre Styles et for-
matage, le bouton le plus a droite,
Nouveau style a partir de la sélection,
permet de créer un style a partir d’un
élément formaté manuellement en
récupérant ses caractéristiques ou
- d’importer des styles définis dans
un autre document grace au menu
Charger les styles.

identity kit hors série



£y

Les modéles,
une extension des styles

Un modéle est un type de document
particulier qui contient des éléments
de mise en page et de formatage
comme les styles, les images, les
tableaux..., et qui sert de base a la
création de nouveaux documents.
Pour créer un modéle de document,
il suffit de créer un nouveau docu-
ment, de lui donner les caractéris-
tiques voulues et de I'enregistrer
grace au menu Fichier -> Modéle de
document -> Enregistrer, en sélec-
tionnant la catégorie de modéles la
plus adaptée. Les modéles sont en
fait des fichiers ayant pour extension
«.ott » et qui se trouvent dans le ré-
pertoire défini dans le menu Outils ->
Options -> OpenOffice.org -> Che-
mins.

Pour éditer ce modeéle ou pour
créer un nouveau document a partir
de ce modeéle, il faut utiliser le menu
Fichier -> Nouveau -> Modéles et
documents, partie Modéles. Pour
créer un nouveau document, il suf-
fit de cliquer sur le modeéle puis sur
le bouton Ouvrir. Et pour modifier
le modéle, il suffit de cliquer sur le
bouton Editer.

OpenOffice.org fournit plusieurs
modeéles prédéfinis (pour chacun des
modules) congus pour vous aider
a créer divers types de documents.
Le menu permettant la gestion des
modéles de documents est Fichier ->
Modéle de document -> Gérer. Un
double-clic sur un modéle donne
sous forme d’arborescence les diver-
ses propriétés du modéle. Cette fe-
nétre permet également de modifier
le modéle par défaut des documents
créés avec OpenOffice.org. En effet,
les nouveaux documents créés avec
OpenOffice.org ne sont pas totale-
ment vierges puisqu’ils possédent
entre autres des styles de base.

Pour définir un modéle comme
modéle par défaut, il suffit de cliquer
avec le bouton droit dans la fené-
tre de gauche du menu Fichier ->
Modéle de document -> Gérer et
de choisir I'entrée Choisir comme
modéle par défaut.

Il est aisé de revenir a la con-
figuration initiale grace a I'entrée
Rétablir le modéle par défaut du
méme menu.
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et réalisation AP
de la structure
du document sur
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Le document que nous
allons réaliser dans cette
partie concerne le publi-
postage avec OpenOffi-
ce.org. Le contenu nous
importe peu ici mais si

Alinéa

A L 1

B b

Alinéa négatif
Confrontation

Corps de texte

Formule finale

Note en marge

Retrait du corps de texte

Signature

cette fonctionnalité vous T!tre
intéresse, vous trouverez Rgg i 0
le document en intégrali- Hitre 2
té dans la partie docu- Titre 3
mentation du site Inter- Titre 4
net francophone : http.// Titre 5
fr.openoffice.org/ Titre 6
Documentation/How-to/ Titre 7
indexht-writer.html. Titre 8
Titre 9
Réalisation
de la page de titre
Pour notre document sur - T
le publipostage, la page | Automatique o

contenant le titre est dis-
sociée des autres : elle
contiendra en particulier
un en-téte et un pied de page diffé-
rent des autres pages. Il est donc
nécessaire de lui affecter un style
particulier.

Pour cela, il suffit de placer le cur-
seur sur la premiére page, de sélec-
tionner dans la fenétre Styles et forma-
tage le bouton Style de page et d’appli-
quer le style « Premiére page » en dou-
ble-cliguant sur I'entrée du méme
nom. Pour I'affectation des styles, il
est également possible de passer par
la barre d’outils Formatage grace a la
liste déroulante située a gauche.

Modifions ensuite ce style pour
lui donner nos paramétres, en cli-
quant avec le bouton droit sur le nom
du style puis en choisissant Modifier.
Nous pouvons par exemple sélec-
tionner, dans I'onglet Gérer, le style
« Standard » comme style de suite
afin que la page suivante ait comme
style « Standard ».

Pour obtenir la mise en forme de
la Figure 3, nous avons inséré des
cadres pour chacun des textes afin
d’avoir une mise en page plus précise
gue si nous avions utilisé les lignes.
Etant donné que ces cadres sont uni-
ques, leur affecter un style a chacun
ne présente pas d’intérét : il est plus

Figure 2. La fenétre Styles et formatage

simple de les formater manuellement
grace au menu Format -> Cadre.

Lors des modifications sur les
cadres, il faut veiller a ne pas confon-
dre les bordures fictives et les bordu-
res réelles.

En effet, pour aider au repérage et
au positionnement des cadres, Open-
Office.org place automatiquement des
bordures fictives grises. Pour éviter des
modifications inutiles sur ces éléments,
disparraissent lors de I'impression ou
de I'export dans d’autres formats, il est
préférable de s’appuyer sur un apercu
avant impression. Les bordures, la
police ainsi que les autres mises en
forme du titre «Le Publipostage »
sont paramétrées dans le style de
paragraphe « Titre principal ».

Les images sont aisément position-
nées grace au menu Format -> Image.
Notons que les images copiées/collées
d’Internet ne sont pas enregistrées par
défaut dans le document : elles sont
présentes sous forme de lien. Par con-
séquent, si le document est ouvert sur
un poste ne disposant pas d’Internet,
I'image ne sera pas visible. Il est ce-
pendant possible d’inclure l'image
dans le fichier en cliquant sur I'image
puis sélectionnant le menu Edition ->
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Figure 3. Page de titre

Lien. Il suffit ensuite de choisir cette
image dans la liste puis de cliquer sur
le bouton Déconnecter.

Réalisation

de la table des matiéres

Une nouvelle page est tout d’abord
créée par le menu Insertion -> Saut
manuel -> Saut de page. Dans ce
menu, choisissons le style « Standard »,
style qui s’appliquera a la nouvelle
page. Pour commencer la numérota-
tion des pages aprés la page de titre,
cochons Modifier le numéro de page
puis choisissons le numéro 1. Les nu-
méros de pages coincideront ainsi
avec les numéros présents dans la ta-
ble des matiéres, en appliquant d’'une
certaine fagon le numéro O a la page
de titre.

Insérons ensuite I'en-téte et le
pied de page grace au menu Inser-
tion, puis affectons-leurs les styles
de paragraphe correspondants. Il ne
reste plus qu’a modifier ces styles
par I'intermédiaire de la fenétre Styles
et formatage pour aboutir a la mise
en forme voulue.

En pied de page, en plus du nom
du fichier, ajoutons la numérota-
tion des pages en introduisant des
«champs » par le menu Insertion ->
Champ. Les types de champs sélec-
tionnés dans notre exemple sont
Numéro de page et Nombre de pages.
Les informations contenues dans cer-
tains champs comme le titre, 'auteur
ou le sujet du document sont définies
dans le menu Fichier -> Propriétés,
onglet Description.
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Passons maintenant a la mise en
place de la table des matiéres et au
paramétrage des titres de chapitres.
La structure générale des titres du
document, qui détermine donc I'or-
ganisation de la table des matiéres,
est définie dans un seul menu :
Outils -> Numérotation des chapi-
tres, dans lequel nous allons définir
pour chaque niveau de titre, un style,
une numérotation et un positionne-
ment. Cette étape est indispensable
car elle permet un paramétrage sim-
plifié de la table des matiéres.

Dans l'onglet Numérotation, at-
tribuons a chaque niveau de titre un
style de paragraphe qui sera ensuite
modifié dans le styliste. Le champ
Numéro permet de définir le type de
numeérotation (lettres, chiffres, chif-
fres romains...) et le champ Style de
caractéres, le style correspondant a
ces numéros ; il peut en effet étre
différent du style du titre proprement
dit. Pour les titres de niveaux supé-
rieurs a 1, il est possible de choisir,
dans le champ Complet, le nombre
de niveaux de titre a inclure dans
la numérotation. Par exemple, pour
un titre de niveau 3 avec le champ
Complet défini a 3, la numérotation
sera de la forme 1.4.2. |l s’avére par-
fois pratique de définir des propriétés
communes a I'ensemble des niveaux
de titre en utilisant le niveau 1-10.

La fenétre Navigateur, accessible
via le menu Edition -> Navigateur ou
en appuyant sur la touche [F5] du
clavier, donne un accés rapide aux
différents objets du document et en
particulier aux titres. Elle donne ainsi
une vue d’'ensemble de la structure
du document.

Linsertion de la table des matié-
res se fait par le menu Insertion ->
Index -> Index (Figure 4). Nous al-
lons conserver les paramétres par
défaut de I'onglet Index pour le titre
et le type d’index («Table des ma-
tieres »).

Dans l'onglet Entrées, il faut pa-
ramétrer la présentation de la table
des matiéres pour chaque niveau.
Prenons I'exemple du niveau 1. Dans
la partie Structure, supprimons tou-
tes les cases avec la touche [Suppr]
du clavier. Puis ajoutons une case
Numéro de chapitre ainsi que les ca-
ses Texte, Tabulation (pour placer la
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Figure 4. Création d’une table des matiéres

numeérotation a droite) et Numéro de
page, en veillant a chaque fois a pla-
cer le curseur dans la case blanche
la plus a droite. Ces cases blanches
permettent d’insérer des caractéres
comme des tirets, des points... La
case tabulation posséde deux pa-
rameétres essentiels : les caractéres
de remplissage (ici des points) et la
position de la tabulation (ici alignée
a droite).

Notre document étant destiné
a une consultation sur écran, nous
allons ajouter des hyperliens sur les
numéros de page pour pouvoir accé-
der aux différentes parties du docu-
ment d’un simple clic sur les numé-
ros de page de la table des matiéres.
Pour cela, encadrons la case numéro
de page par une case de début d’hy-
perlien (DH) et une case de fin d’hy-
perlien (FH), les deux étant insérées
grace au méme bouton : Hyperlien.
N’importe qu’elle élément de la table
des matiéres peut contenir un hyper-
lien : titre, numéro de page...

Les styles des entrées de la ta-
ble des matiéres sont défnis grace
a l'onglet Styles. Il faut veiller a ne
pas confondre les styles des titres
du document, paramétrés dans le
menu Outils -> Numérotation des
chapitres, et les styles des titres de
la table des matiéres ! Pour chacun
des niveaux, les deux doivent donc
étre différents.

Aprés avoir complété les autres
onglets et configuré les autres ni-
veaux de titres nécessaires, cliguons
sur OK. La table des matiéres qui
apparait est quasiment vide puis-
qu’elle ne contient que le titre. Mais
il nest pas nécessaire de la remplir
car désormais, elle se remplira auto-
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matiquement a chaque fois que I'on
affectera a un titre les styles Titre 1,
Titre 2... (ceux définis dans le menu
Outils -> Numérotation des chapi-

tres). Des éclaircissement seront
apportés dans la suite de I'article.

Pour modifier la configuration de
la table nouvellement créée, il suffit
de cliquer avec le bouton droit sur
I'index puis de choisir Editer I'index.

Le champ Type de I'onglet Index
du menu Insertion -> Index contient
d’autres types d’index prédéfinis,
d’utilisation relativement similaire
et permet aussi la création index
personnalisé.

Réalisation

du corps du document

Prenons juste I'exemple de la pre-
miére page car le fonctionnement
des titres est identique dans tout le
document.

Introduction...........

fr.OpenOffice.org
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Aprés avoir introduit un nouveau
saut de page a la suite de la table
des matiéres, nous allons inscrire le
premier titre : « 1% Partie —-> Débuter
avec le publipostage » et lui appliquer
le style Titre 1 (modifié a notre golt
dans le styliste). Pour observer les
changements dans la table des ma-
tiéres, cliquons dessus avec le bou-
ton droit, et choisissons Actualiser
I'index. On constate qu’une entrée
correspondant a notre titre est ap-
parue dans la table des matiéres.
Le style de cette nouvelle entrée
dépend du style choisi pour le niveau
de titre 1 lors de la création de la ta-
ble des matiéres. Il s’agit par défaut
du style de paragraphe «Table des
matiéres niveau 1 », modifiable avec
le styliste.

Nous opérerons de la méme fagon
pour la rédaction de la suite de la page
puis du document et ne modifierons
donc jamais directement le contenu
de la table des matiéres. Si toutefois,
vous souhaitez le faire, désactivez I'op-
tion Protégé contre toute modification
manuelle par un clic avec le bouton
droit sur la table des matiéres, Editer
I'index, onglet Index. Mais notons que
le contenu des titres eux-mémes ne
pas dépend pas du contenu de la
table des matiéres : c’est I'inverse.
Pour générer de nouveau automati-
guement la table des matiéres, c’est-
a-dire revenir sur vos modifications,
il suffit d’actualiser I'index.

Quelques objets
et outils de présentation

La plupart de ces objets sont dispo-
nibles dans d’autres modules que
Writer et leur fonctionnement y est
similaire.

Les tableaux et les graphiques
Bien que ces fonctions sont plutdt
réservées a Calc (le tableur), il est
possible de manipuler des tableaux
et des graphiques dans Writer. Un
menu entier est réservé aux ta-
bleaux et son utilisation est assez
élémentaire. Notons simplement que
modifier la taille d’'un tableau néces-
site de préciser que 'alignement est
Manuel dans le menu Tableau ->
Propriétés du tableau onglet Tableau
car l'alignement Automatique fige la
taille du tableau.

La Figure 7 présente un exemple
de tableau. Vous constaterez que ce
tableau posséde une légende, qu'il
est facile d’insérer en cliquant avec
le bouton droit sur le tableau, menu
Légende.

Enfin, la version 2.0 d’Open-
Office.org apporte une fonctionnalité
intéressante puisque I'on peut dé-
sormais d’imbriquer les tableaux les
uns dans les autres, ce qui permet
également d’améliorer la compatibi-
lité avec Microsoft Word, qui posséde
également cette fonctionnalité.

Pour générer un graphique a par-
tir d’un tableau créé dans Writer, il est
nécessaire de spécifier le caractére
numérique des données présentes
dans le tableau : menu Tableau ->

Format numérique. La manipulation
des graphiques et les divers types
de représentations proposés seront
décrits dans l'article consacré au
tableur Calc.

Les listes

Writer propose deux types de listes :
les listes a puces et les listes numé-
rotés. Leur insertion se fait soit avec
les deux boutons correspondants
situés sur la barre d’outil Formatage,
soit grace au menu Format -> Puces
et numérotation. La barre d’outils
Puces et numérotation permet
d’accéder plus rapidement a une
partie des propriétés des listes. Le
styliste offre pour les listes les méme
possibilités de paramétrage que les

ple trés b quif

publipostag

dessous résume les opérations.

Document de fusion

fr.OpenOffice.org

1% Partie — Débuter avec le publipostage

Ce document décrit les fonclionnalités offertes par OpenOffice.org v.2 en matiére de publipostage.
Aprés avoir défini les éléments intervenant dans cette opération, nous effectuerons un
bli de comprendre les notions qui s'y rapportent.

1 Les éléments d'un publipostage

Pour pratiquer un mailing nous devons disposer de deux éléments ou ensembles d'éléments
différents. Tout d'abord, un document « & trous » ou document de fusion, plus connu sous le nom
de leftre-type, qui comporte la mise en forme générale des données. Ensuite, un ensemble de
données variables, destinées & combler les « trous » du document de fusion. Le diagramme ci-

Données variables

M

fusion

figure 1: Le principe du publipostage

GuidePublipostage. odt

Résultat de la fusion

5/55

Figure 6. Premiére page du document
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autres éléments grace a la catégorie
« Styles de liste ».

Il est possible pour chaque liste,
de définir le style des puces (carac-
téres spéciaux ou images) ou de
numeérotation, le « plan », c’est-a-dire
la hiérarchisation des puces et des
numeéros, ainsi que les espacements,
les alignements... Par défaut, huit pu-
ces différentes sont proposées, mais
I'on peut en ajouter d’autres avec
I'onglet Options, case Caractéres.

On peut également créer ses pro-
pres puces, sous forme d’'image, et
les insérer en sélectionnant une
image quelconque de I'onglet Image
puis en utilisant la case Sélection ->
A partir d’un fichier de I'onglet Op-
tions. De nombreux formats sont uti-
lisables parmi lesquels le jpeg, le
png, le gif, le svg, le bmp, le tiff...

Les formules scientifiques,
flexibles et polyvalentes

Parmi les objets indispensables a
la rédaction de documents scientifi-
ques, les formules figurent en bonne
position. OpenOffice.org posséde un
module dédié : Math, mais son uti-
lisation indépendamment de Writer
présente peu d’intérét.

Linsertion d'une formule dans
Writer s’effectue par le menu
Insertion -> Objet -> Formule. Une
fenétre Sélection apparait alors,
contenant un cadre de saisie en bas
de la page. La syntaxe a utiliser est
décrite dans I'aide mais I'utilisation
de la fenétre Sélection, contenant la
majorité des symboles disponibles,
peut s’avérer parfois plus directe.

Les lettres grecques ainsi que
d’autres caractéres spéciaux sont
accessibles via le menu Outils ->
Catalogue auquel il est possible
d’ajouter des caractéres provenant
d’autres polices (voir I'article Foire
Aux Questions).

Le menu Format permet, quant
a lui, de paramétrer la taille et la po-
lice des caractéres utilisées dans la
formule, les espacements ainsi que
les alignements. Chaque formule
est indépendante et comme tous les
objets, le positionnement sur la ligne
et dans le paragraphe de la totalité
des formules du document est pa-
ramétrable grace a la fenétre Style
et formatage.
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Titre 1
Titre 3
Tured
Titre 5§

Titre 6

Tableau 1: légende du tableau 1

Titre 2

Figure 7. Exemple de tableau

Toutefois, ce module ne sert pas
uniquement pour les formules ma-
thématiques. Il s’avére également
trés pratique pour les équations-bi-
lan ou les symboles des éléments en
chimie, entre autres.

Par exemple, pour [lisotope
239 du plutonium, Pu  1lsub{94)
lsup(239) donne Z%PU. Les guille-

mets permettent de supprimer l'ita-
lique désignant les variables s’ap-
pliguant automatiquement a toutes

les lettres. Pour [I'autoprotolyse
de l'eau, 2»H»_2»0» toward «H»_
30> {{}+(})} + OH"{{]-{}}donne

2H,—>H,0*+0H . Le - utilisé seul
correspondant a l'opérateur, il est
nécessaire d'utiliser 'artifice suivant
{1-{} pour simuler la présence d’un
caractére a droite et a gauche sinon
Math renvoie une erreur : H,0%¢
D’autres astuces concernant la syn-
taxe sont présentes dans la FAQ.

Les colonnes et les sections
Certains documents nécessitent la
création de colonnes. |l est aisé d’in-
sérer et de paramétrer des colonnes
sous Writer avec le menu Format ->
Colonne dans lequel de nombreuses
options sont disponibles : nombre
de colonnes, espacements, traits de
séparation...

Lors de l'association d’'une mise
en page en colonne a un style de
page particulier dans la fenétre
Styles et formatage, les colonnes
vont alors s’appliquer sur 'ensemble
de la page. Pour faire apparaitre sur
une méme page des parties avec
colonnes et des parties sans, voire
des parties possédant un nombre de
colonnes différent, on peut utiliser
I'outil des sections.

Une section désigne une portion
de document indépendante des
autres. Plusieurs sections peuvent

coexister au sein d’'un méme docu-
ment et une section peut en contenir
une autre. Elles sont paramétrables
par le menu Insertion -> Section
dans lequel vous remarquerez un
onglet consacré aux colonnes.

Les sections permettent en outre
de ne pas faire apparaitre une por-
tion du document a l'impression,
de la protéger contre I'édition ou de
faire apparaitre un paragraphe selon
qu’une condition soit remplie ou non.
Par exemple dans une lettre, la for-
mule de politesse varie en fonction
du contenu de I'intitulé : M ou Mme.

On peut enfin insérer grace aux
sections, un autre document ou la
section d’'un autre document, dans
le document actif. Ceci permet de
modifier automatiquement un docu-
ment en fonction du contenu d’'un
autre.

Les notes de bas de page

Writer permet I'insertion de notes de
bas de page de facon relativement
simple, en passant par le menu
Outils -> Notes de bas de page ou
il est possible de paramétrer, entre
autres, le type de numérotation, le
choix de regrouper les notes en fin
de document ou a la fin de chaque
page ainsi que le style de ces notes,
modifié par la suite dans la fenétre
Styles et formatage.

Utilisez ensuite le menu Inser-
tion -> Note de bas de page a 'en-
droit ou vous souhaitez insérer le
numéro. Ce dernier se positionnera
automatiquement en exposant mais
on peut en modifier la mise en forme
en éditant le style de caractéres
choisi dans la fenétre Edition ->
Note de bas de page, section Style
de caractére, entrée Zone de texte
(par défaut ce style est « Appel de
note de bas de page »).
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fichiers texte (.txt,
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CSV)

tables de base de données dBase (.dbf);
tables de base de données OpenOffice Base |
tables de bases de données externes accessil

Figure 8. Exemple de liste

Un trait horizontal de séparation
apparaitra également en bas de
page ou de document en fonction de
I'option choisie. Ce trait peut étre
modifié ou supprimé en éditant le
style de page choisi, onglet Note de
bas de page.

La Gallery

La Gallery, accessible par le menu
Outils -> Gallery, est une bibliothéque
d’'images et de sons contenant par dé-
faut, des arriéres plans (textures), des
régles, des boutons, des puces, ...

On peut y ajouter ses propres
images ou créer des thémes con-
tenant plusieurs images. Sur le site
Internet http;//www.openclipart.org/
vous trouverez de nombreuses ima-
ges sous licence libre et donc utilisa-
bles dans vos documents.

Utilisations des hyperliens
Le menu Insertion -> Hyperlien
contient des assistants pour la créa-
tion d’hyperlien Internet, FTP, Mails
et méme de liens internes au docu-
ment. Il dispose d’options comme le
choix de la fenétre d’apparition, la
forme (texte, bouton), ...

Lors de l'insertion d’hyperliens,
il faut considérer le caractére relatif
ou absolu des hyperliens. Le para-
métrage par défaut d’OpenOffice.org
peut étre modifié dans le menu
Outils -> Options -> Chargement/
Enregistrement -> Général, champ
Enregistrement relatif des URL.

Il est facile d’accéder aux diffé-
rents hyperliens du document grace
au navigateur.

Aides a la rédaction

Il est fréquent que plusieurs per-
sonnes travaillent sur le méme do-

cument ou de revenir sur un ancien
document. OpenOffice.org dispose
donc d’outils afin d’aider la rédaction
des documents ainsi que le travail
communautaire.

Vous pouvez insérer dans vos
documents des notes (Insertion ->
Note) qui permettent de commenter
un passage du texte, ou des repéres
de texte pour marquer un endroit pré-
cis du texte a l'instar des marques-
pages ou des signets. Ces repéres
sont invisibles mais sont accessibles
avec le navigateur ou en cliquant
avec le bouton droit dans la case
Page X/Y de la barre d’état.

Quant aux notes, elles sont re-
pérées par un rectangle jaune qui
n'apparait évidemment pas a l'im-
pression. Elles sont également gé-
rées grace au navigateur.

Lors de la rédaction d’'un docu-
ment par plusieurs personnes, il est
souvent nécessaire de connaitre les

modifications effectuées par chacun
des rédacteurs. Le menu Edition ->
Modifications est fait pour cela.

En activant I'entrée Enregistrer
de ce menu, toutes les modifications
apportées au document sont enre-
gistrées et peuvent étre affichées
(Edition -> Modifications -> Affi-
cher) sous la forme définie dans
Outils -> Options -> OpenOffice.org
Writer -> Modifications. Pendant la
rédaction, il est plus simple de dé-
sactiver I'affichage de ces modifica-
tions en décochant Edition -> Modi-
fications —> Afficher.

Par la suite, le rédacteur princi-
pal acceptera ou refusera les modifi-
cations faites, grace au menu
Edition -> Modifications -> Accep-
ter ou rejeter.

Il est possible dans cette fenétre
d’accepter manuellement chacune
des modifications ou d’utiliser un
filtre afin d’automatiser cette procé-
dure, par date et/ou par auteur no-
tamment.

Les fonctions
de recherche

Le menu Edition -> Rechercher &
remplacer permet non seulement de
rechercher des chaines de caractéres
et de les remplacer par d’autres mais
aussi de remplacer des styles (styles
de paragraphe uniquement). Si vous
ne connaissez pas exactement I'or-
thographe d’un mot, procédez a une
« recherche de similarité ».

et OpenOffice.org ?

dérable de OpenOffice.org,

Quelles difféerences entre MS Office

Pour les fonctions de base, il y a assez peu de différences entre
OpenOffice.org et MS Office. En voici quelques-unes :

La fenétre Styles et formatage ainsi que la fenétre Navigateur, qui sont
un des apports importants de la suite bureautique libre,
Le module Math pour la création de formules scientifiques, atout consi-

Les diverses possibilités de personnalisation du logiciel
d’outils, menus, raccourcis clavier...,

Calc, en revanche présente quelques faiblesses listées dans un docu-
ment écrit par Tony Galmiche et disponible sur le site internet http://
fr.openoffice.org/Marketing/matexpo/Documents/index.html,
Impress a beaucoup progressé avec la version 2.0 et son niveau lui
permet aujourd’hui de concurrencer Microsoft PowerPoint.
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des utilisateurs.

OpenOffice.org, un logiciel adaptable

Apreés l'installation d’OpenOffice.org, il peut étre intéressant d’explorer le
menu Outils -> Options qui permet d’adapter OpenOffice.org aux besoins

OpenOffice.org permet également la personnalisation des barres
d’outils. Il dispose d’'un menu assez complet a ce sujet : Outils ->
Personnaliser qui permet notamment de compléter les barres d’outils exis-
tantes ou d’en créer de nouvelles, de configurer les raccourcis clavier ou
encore de modifier certains menus (Fichier, Edition, Format, Tableau...).

L'organisation des barres d’outils est aussi trés souple : elles sont aisé-
ment détachables, redimmensionnables et modulables.

Ce menu permet également de
remplacer des expressions régu-
lieres par d’autres. Si par exemple
vous souhaitez remplacer tous les
retours a la ligne par une virgule,
il suffit de vous rendre dans le menu,
de cliquer sur le bouton Autres op-
tions, de cocher Expressions régu-
lieres et de saisir « \n » dans la case
Rechercher puis une virgule dans la
case Remplacer par.

Pour avoir une liste de toutes les
expressions réguliéres ou pour plus
de précisions sur les fonctions de
recherche dans OpenOffice.org, con-
sultez I'aide ou le tutoriel réalisé par
Jean-Francois Nifenecker et disponi-
ble dans la partie Documentation du
site Internet francophone : http;//
fr.openoffice.org/Documentation/
How-to/indexht-writer.html.

Les assistants
redactionnels
et de conversion

Le menu Fichier -> Assistants pré-
sente des outils destinés a simplifier
des taches répétitives telles que la
rédaction d’une lettre ou d’un fax, la
création d’un agenda, d’une présen-
tation multimédia ou d’une page
Web.

www.linuxidentity.com

Ce menu propose également un
convertisseur pour les documents
provenant de StarOffice ou Microsoft
Office.

Enfin, il contient deux autres as-
sistants qui permettent d’installer
des dictionnaires dans de nombreu-
ses langues ainsi que des polices de
caractéres, dont des polices Microsoft
utilisables librement comme le Time
New Roman, le Comic Sans MS, le
Trebuchet MS, ... (voir I'article consa-
cré aux extensions pour plus de préci-
sions).

Certains de ces assistants requié-
rent l'installation du JRE (Java Run-
time Environment : http://www. java.

com/fr/download/manual.jsp), en gé-
néral fourni avec OpenOffice.org.

OpenOffice.org
et le HTML

Nous avons vu dans le paragraphe
consacré aux assistants qu’OpenOffi-
ce.org permettait la création de sites
Internet, grace au menu Fichier ->
Assistants -> Page Web.

Cet assistant aide au démarrage
du projet en construisant la structure
et la charte graphique du site Internet.
Par la suite le développement se dé-
roule soit en mode WYSIWYG (What
you see is what you get), soit avec
I'éditeur de texte inclus, accessible via
le menu Affichage -> Source HTML
présent dans les documents HTML
créés avec Fichier -> Nouveau ->
Document HTML.

Il est également possible d’expor-
ter un document texte ou une feuille
de calcul directement en HTML, en le
spécifiant a I'enregistrement.

Méme si les systéemes de géné-
ration de code automatique comme
celui-ci ne sont pas l'idéal, il s’avére
gu’OpenOffice.org produit du HTML
de bonne qualité et dépasse large-
ment ses concurrents (FrontPage
entre autres) dans ce domaine, du
point de vue des normes W3C. =

AutoCorrection

AutoCorrection.

Les automatismes d’OpenOffice.org peuvent s’avérer dérangeants. Mais
si I'on sait les maitriser, ils peuvent faciliter grandement la rédaction de
document. Leurs paramétrages se modifient dans le menu Outils ->

Par exemple, pour supprimer la mise en majuscule automatique du
premier mot de chaque phrase, il suffit de décocher I'option Majuscule en
début de phrase de 'onglet Options.

Longlet Remplacement permet, quant a lui, de donner automatique-
ment la bonne orthographe a un mot. Longlet Insertion automatique per-
met de compléter automatiquement certains mots lors de la saisie.




